Problem
When activating SmarterStats, SmarterMail, or SmarterTicket, an error message similar to the one below appears:
File or assembly name XXXXX.dll, or one of its dependencies, was not found
The file name reported by the error is completely random.
You may also receive an error saying that you cannot communicate with the activation server.
Cause
Permissions are set incorrectly for the C:\Windows\Temp or C:\WinNT\Temp directories
Solution
Make sure that the "network service" user has permissions to modify the contents of the folder mentioned. Note: This is the "ASPNet" user in Windows 2000 and Windows XP.