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HomeKnowledge BaseTroubleshooting: "Unable to generate a temporary class" in products using .Net 2.0
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Article ID227
Created On5/8/2008
Modified5/8/2008
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Troubleshooting: "Unable to generate a temporary class" in products using .Net 2.0
Software affected: SmarterMail 4.x and higher, SmarterTrack 3.x and higher

Problem:

Activation fails or you notice an error in your logs that looks like the following:

System.InvalidOperationException: Unable to generate a temporary class (result=1).
error CS2001: Source file 'C:\WINDOWS\TEMP\0kvvmynh.0.cs' could not be found
error CS2008: No inputs specified


(Note, the source file is randomly generated)

You may also see the error "'There was a problem with activation. Verify that the product key you entered is correct, and that it is for this version of [ProductName]" when activating.

Cause:

This exception occurs when the system cannot write necessary temporary files when executing web service calls.

Resolution:

Grant the user account that the web interface is running under List Folder Contents and Read permissions on the %windir%\Temp folder.  Usually this is the "ASPNET" or "Network Service" user.

More Information:

http://support.microsoft.com/kb/908158